Thursday 21 July 2016

Copying a SuperCluster Zone

Copying a SuperCluster Zone


1. Snapshot the original zone
zfs snapshot -r zones/zone1@copy
2. Copy the snap across to the destination zoneroot
zfs send -vr zones/zone1@copy | zfs recv -v zones/zone2
3. Export the zone config and copy it across to the new zone. (use IB if possible)
4. Edit the zone config to reflect new address and new zonepath
5. Create the new zone
6. Attach and boot the new zone
7. Configure the new zone
Name
Solaris 11
sysconfig create-profile -g identity -o config.xml
sysconfig configure -g identity -c config.xml
Solaris 10
Sysunconfig
Edit /etc/nodename, /etc/hostname.*, /etc/hosts

Host files
vi /etc/hosts
IP
Solaris 11
ipadm delete-addr ipmp0/v4
ipadm delete-addr ipmp1/v4
ipadm create-addr -T static -a 23.88.34.157/24 ipmp0
ipadm create-addr -T static -a 192.168.55.61/22 ipmp1
ipadm set-ifprop -p standby=on -m ip net2
route -p add default 23.88.34.1
Solaris 10
vi /etc/hostname.*
vi /etc/defaultrouter
reboot
Samba config
vi /etc/samba/smb.conf
net join -U user -S ADservername
rm /export/home/samba/*/.ssh/known_hosts
Reboot
8. Configure the storage from the ZFS
Log into the appropriate zfs head:
Shares -> Projects: Add new project
Edit Project:
Under General set Mountpoint to /export/projectname
Under protocols:
Share mode=none
Add NFS Exception: Network - IB IP of zone/32 - Read/write - tick root access
Under shares, add shares needed
Go into each share and set quota
vi /etc/vfstab
mount -a
Change ownership of each mountpoint
9. Put key authentication into place between original and copy.
10. Rsync the NFS shares from original to new zone

rsync -azh /u01 192.168.55.61:/